SDK Installer

The Apache Flex® SDK Installer is an application that simplifies the download and installation of the Apache Flex® SDK and its (required) components. It is aimed at anyone who wants to use the latest release of the Apache Flex SDK, but who might not necessarily be familiar with the tools and procedures required to compile the Apache Flex SDK from source code. The application will grab the official, current release of the SDK from apache.org, install it onto your computer and prepare it for use with Adobe Flash Builder. Use the badge below to download the Apache Flex SDK Installer.

Problems with the installer ? Read the installation help on the Wiki.

In particular, Linux users should use the Ant-based method in the above link.

Alternatively, you can download the source and/or binaries for the Apache Flex® SDK Installer directly:

Note: the installer downloads other files besides the Apache Flex SDK. These files are needed for the proper functioning of the SDK. The required TLF and the OSMF frameworks, as well as the optional Embedded Font Libraries and Utilities and BlazeDS are mentioned separately in the installer application. The other non-Apache files downloaded by the installer are:

Download Apache Flex® SDK Installer 3.1 (source)

The Apache Flex team is pleased to offer this 3.1 release of the Apache Flex® SDK Installer, available as of 14 July 2014.

Download Apache Flex SDK Installer 3.1 (binaries)

Binaries are provided as a convenience for those who do not wish to compile the installer themselves. The 3.1 binaries were published on 14 July 2014. There is no 3.1 binary for Linux as all recent Flex and FlexJS SDK's support installation via Apache Ant and it was determined that Linux users preferred the Ant method over having to install Adobe AIR to install the SDK.